Firefox 3.0.1 and Your Add-ons Not Working

Has Firefox 3.0.1 given you trouble?  Well it sound like you might want to contact the extension’s author to make sure thy are using the right compatibility range. Once again Basil does a great job at explaining this in a way that should make sense to us all.

When add-on authors publish their add-on they declare the compatibility range for an add-on. It typically looks like “2.0 to 3.0.*” – meaning that at minimum, this add-on requires Firefox 2.0 and works with any maintenance release of Firefox 3.0. (End of the compatibility range is also called the maxVersion).

Some add-on authors have erroneously used “3.0″ as their maxVersion so when users with these add-ons upgrade from Firefox 3.0 to Firefox 3.0.1, the add-on gets disabled. We encourage these add-on authors to use “3.0.*” as their maxVersion.

So shoot your favorite extension authors an e-mail and ask them to get this fixed, or check to see if this might be the problem.  Another suggestion for people with lots of problems would be to try running Firefox with a new profile or Safe Mode.  In Safe Mode, you can reset some settings or disable extensions and themes that might be the source of the issue. By comparing Firefox behavior in normal mode to its behavior in Safe Mode with various items disabled, you may be able to diagnose issues.

, , , ,

Comments are closed.